Excel Exercise 1:

Goals:
1. Become familiar with Guidelines for spans and proportions of common spanning
members (Chapter 1).
2. Become familiar with basic commands in Excel for performing simple tasks and for
organizing and arranging data.

Requirements:
1. Information in Chapter 1 of the book.
2. A computer with Microsoft Excel.

Comments:
Understanding and calculating spans and proportions for common structural members is more
important than anything else you will do in structural design.

Instructions:
O Create a new Blank Workbook in Excel.
O Save the workbook as DigitalLabl-YourName.

Within the spreadsheet, columns are labeled with letters and rows are labeled with numbers.
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Cells can contain a variety of inputs, including, but not limited to:
e Text
e Numbers
e Formulas for performing computations

O Incell Al, type: Spanning system
O Press Enter
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The words extend beyond cell A1. If data is typed into cell B1, the overlapping text from cell

Al will be hidden by the new text. Column A should be widened to adjust to the width of the

text.

O Double click the line in the header which separates columns A and B. The cell
automatically adjusts to the correct width.
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To more precisely set the column width:

O Click on the A at the top of column A.

O Go to Format=>Column=Width.

O In the Column Width popup, in the Column Width field, type in any number and click OK.
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To precisely set row height:
O Click the number of any row.
0O  With the row highlighted, go to Format>Row=>Height.

Any column or row can also be resized by placing the cursor on the line separating the row or
column and dragging to resize.

Global changes can be made to the spreadsheet by clicking the corner box in the header
(above row 1 and to the left of column A). This highlights the entire spreadsheet, after which
many things can be changed, including the global column width, global row height, font type,
and text size, etc.

O Click on cell Al.

O Hold down Ctrl and the B key at the same time (Ctrl+B) to bold the text. (Or click the
Bold Icon — B — in the toolbar, but keyboard shortcuts are faster when you know
them.)

O Incell A2, type: Very shallow, wide-flange beam

O Press Enter. Now in cell A3, type: Shallow, wide-flange beam

O In cell A4, type: Deep, wide-flange beam

O Incell A5, type: Very deep, wide-flange beam

O Make Column A wider to fit the new width of text.
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In cell B1, type: Divider. Notice that the word is left justified.

Highlight column B.

Hold down Shift and click on K. (If you need to, use the scroll bar at the bottom of the
sheet to scroll over to column K.)

With columns B through K highlighted, click on the center alignment icon at the upper
right of the toolbar.

ooo

d

Type aquestion forhelp = - & X
0 - | B |E[E] % A-
O Click and drag from cell B1 to K1 to highlight the first cell in each of those columns. Make
the cells bold.
O Incell C1, type: Multiplier.
O Press Tab. Now in cell D1, type: Span.
O Click and drag from cell Al to cell D5 to highlight those cells.
O Click and drag on the bottom line of the black rectangle surrounding the highlighted cells.

Drag down two rows to move the contents of the cells.
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Click on cell D3. Move cell D3 up two rows.
In cell D2 type: L

Make cell D2 bold.

In cell D3 type: (ft)

In cell B4 type: 28

In cell B5 type: 24

In cell B6 type: 20

In cell B7 type: 18

oooooooo
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| 1| Span
L2 | L

| 3 |Spanning system Divider Multiplier (ft)

| 4 |Wery shallow, wide-flange beam 28

| & |Shallow, wide-flange beam 24

| B |Deep, wide-flange beam 20

| 7 |Wery deep, wide-flange beam

The upper and lower extreme values of these “dividers” are from page 29 of Chapter 1, for the
proportions of wide-flange beams. They represent the extreme range of proportions for wide-
flange beams. The two intermediate dividers are included to give more typical proportions
than the extremes. These dividers are used to calculate the depth of the beam. Beam depth
is found by dividing the Span L by the divider. These dividers are left from the days when we
only had slide rules or our brains to perform simple computations. These dividers give good,
economic proportions, and are also memorable and easy to manipulate.

For example:

20 is easy to remember and to divide by 2 and 10 in our heads.

24, as a factor of 12, is very easy to manipulate within the imperial system of units (feet and
inches). We divide the length of the beam’s span, in feet, by 2. The resulting number is the
depth of the beam in inches.

This is still the most common first step in estimating the depth of a wide-flange beam. Today,
we have calculators and spread sheet programs. Such creative mental manipulation of
numbers is no longer as crucial as it used to be.

The best way to start the calculations is with the span, which we know, and move on to the
depth, which we are trying to estimate®.

O Incell C4 type: =1/B4
O Press Enter.

The equal sign is the method of telling Excel that you want it to perform a computation. The
end product of that computation is displayed in the cell.
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| 11 Span
| 2 | L
| 3 |Spanning system Divider Multiplier (ft)
| 4 |Wery shallow, wide-flange beam 28 0.035714
| 5 |Shallow, wide-flange beam 24 1
| B |Deep, wide-flange beam 20
| 7 |Wery deep, wide-flange beam 18

Tt might seem more appropriate to express the process in terms of a multiplier. For some situations, we
will do that, since there is often confusion in the fact that the larger divider leads to a shallower beam.
Multipliers have the advantage that the larger multiplier corresponds to the deeper beam. Dividers,
however, express an aspect of proportions that our minds grasp fairly easily. They represent how much
longer the beam is than it is deep. We are better able to visualize a beam that is 20 times longer than it
is deep than we can a beam that is 0.05 times as deep as it is long.
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To display text starting with an equal signh without Excel performing the calculation, put a
single quote in front of the expression.

O Incell E3 type: ‘=1/B4

O Press Enter. Excel simply displays the expression after the single quote as a text string,
rather than doing any computation.

O Highlight cell E3. Press Backspace to clear the cell.

O Click on cell C4. The formula is displayed in the formula bar above the column headers,
the generated the number is displayed in the cell. If you wanted to edit the formula,
you would do so in the formula bar.
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4 |Wery shallow, wide-flange heam 28 ID.DSS?M!
| 5 |Shallow, wide-flange beam 24
| 6 |Deep, wide-flange beam 20
| 7 |Wery deep, wide-flange beam 18

O Click the Decrease Decimal icon in the toolbar until there are only three digits shown after
the decimal.
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Decrease Decimal

The Increase Decimal icon is to the left of the Decrease Decimal icon. Using these icons does
not change the accuracy to which the computations are being performed. It simply changes
how many figures are being displayed. Since we have a hard time remembering or even
evaluating too many figures, we are reducing the number to three digits after the decimal,
which in this case is only two significant figures. The fraction 0.036 is the multiplier, that is,
the number by which we would multiply the length to get the depth.

O Highlight cells C4 through C7.
O Hold down Ctrl and press the D key (Ctrl+D). This is called Fill Down?.

This creates formulas in all the cells below C4. These formulas are automatically adjusted to
correspond with the correct cells. For example:

0O Click cell C7. The formula =1/B7 appears in the formula bar.

2 An alternate method is Edit>Fill>Down. You may also Fill Right with Ctrl+R.
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| 1| Span
2| L
| 3 |Spanning system Divider Multiplier (ft)
| 4 |Wery shallow, wide-flange beam =] 0.036
| & |Shallow, wide-flange beam 24 0.042
| B |Deep, wide-flange beam 20 0.050
| 7 |Wery deep, wide-flange beam 18 I 0.056 _l
O In cell D4 type: 32
O Highlight cells D4 through D7.
O Fill Down (Ctrl+D)
O Incell E1 type: Depth
O Incell E2 type: d
O In cell E3 type: (ft)
O Incell F1 type: Depth
O Incell F2 type: d
O In cell F3 type: (in)
O Make cells E2 and F2 bold, if they are not already.
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| 1| Span Depth Depth
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| 3 |Spanning system Divider Multiplier (ft) (ft) {in)
| 4 Wery shallow, wide-flange beam 28 0.036 32
| & |Shallow, wide-flange beam 24 0.042 32
| B |Deep, wide-flange beam 20 0.050 32
| 7 |Wery deep, wide-flange beam 18 0.056 32
O In cell E4, type: =D4/B4
O Press Enter
O Incell F4, type: =E4*12
O Press Enter

An asterisk is used to instruct Excel to do a multiplication.

O Reduce the number of digits shown after the decimal to three for both cells E4 and F4.
O Highlight cells E4 through F7.
O Fill Down
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| 1 Span Depth Depth

| 2 | L d d

| 3 |Spanning system Divider Multiplier (ft) (ft) {in]

| 4 |Wery shallow, wide-flange beam =] 0.035 32 1.143 13714

| & |Shallow, wide-flange beam 24 0.042 32 1.333 16.000

| B |Deep, wide-flange beam 20 0.050 32 1.600 19.200

| 7 |Wery deep, wide-flange beam 18 0.056 32 1.778 21.333
O Incell G1, type: Maximum
O Incell G2, type: Span
O In cell G3, type: Commonly
O In cell G4, type: Used
O In cell G5, type: (ft)
O In cell G6, type: Get from
O Incell G7, type: Tables
O Highlight cells G1 through G7.
O Ctrl+1. This brings up the Format Cells popup®.
O In the Format Cells popup, click the Border tab.
O In the Format Cells popup, in the Line Box, under the Style heading, click the icon of the

thickest line.

O In the Format Cells popup, under the Border heading, click the icon with a solid vertical

line on the left of the dashed grid within it. This will make a thick, vertical line appear
on the left within the preview box.

Format Cells

Mumber | Alignment Font | Border | Patterns | Protection
W | Presets Line

Mone Qutline  Inside
Border

}
Text T

:

Text

- Color:

The selected border style can be applied by clicking the presets, preview
diagram or the buttons above,

[ Ok I[ Cancel ]

O In the Format Cells popup, click OK.

A bold line now separates the data.

3 Also: Format=>Cells
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L1 Span Depth Depth  Maximum
| 2 | L d d Span
| 3 |Spanning system Divider Multiplier (ft) (ft) {in) Cornrmonly
| 4 |Wery shallow, wide-flange heam 28 0.036 32 1.143 13714 Used
| & |Shallow, wide-flange beam 24 0.042 32 1.333 16.000 (ft)
| B |Deep, wide-flange beam 20 0.050 32 1.600 19.200 | Get from
| 7 |Wery deep, wide-flange beam 158 0.056 32 1.778 21.333 Tables

Using lines to visually organize a spreadsheet is invaluable. In this case, the heavy line
suggests a break in the continuity of the process: everything to the left of the heavy line has
to do with computations for a particular specified span. The cells to the right of the line
involve information retrieved directly from the figures on spans and proportions in Chapter 1
of the textbook.

Another important organizing tool, is the insertion or deletion of rows, columns, and cells.
O Click on C. With column C highlighted, right click and click Insert.

A new, blank column appears, while the data formerly in column C has been moved to the
right.

O With column C still highlighted, right click again and click Delete.
The data moves back to its original location. The same may be done for rows and cells.
Homework:

Using data from the tables on spans and proportions (Fig. 1-37), in your book, use the

methods from this exercise to:

O Format your spreadsheet to match the one listed below.
O Input data from tables and create formulae to complete the spreadsheet.

Note: The length at which a member is shown in the tables is the Maximum Span Commonly
Used for that member.
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L Span Depth Depth IMaximum
| 2 | L d d Span
| 3 | Spanning system  Divider Multiplier ft) [ft) fin) Commanly
| 4 | Lsed
| = | (it
| 6 | Get from
| 7 | Simple-span, wide-flange beam Tables
| 8 | Wery shallow | 28 0.036 32 1143 | 13714
L8 | Shallawy 24 0042 32 1.333 16.000
|10 | Ceep| 20 0.050 32 1600 | 19.200
|11 | Wery deep 18 0.036 32 1778 21.333

12
|13 | Cantilevered, wide-flange beam
| 14 | Wery shallow 14 16
115 | Shallewe | 12 16
|16 | Deep 10 16
117 | Wery deep 9 16
kel
| 19 | Simple-span, plate-girder
|20 | Shiallersy 100
| 21 | Deep 100
22 |
| 23 | Cantilevered, plate-girder
|24 | Shiallersy 50
| 23 | Deep al
26|
| 27 | Steel Fink Truss
|28 | Shialleray 200
| 29 | Deep 200
30|
| 31 | Standard, double-angle,
| 32 | parallel-chord truss
| 33 | Wery shallow 32
|34 | Shallewe | 20 32
| 35 | Deep 16 32
| 36 | Wery deep 32
37 |
| 35 | Steel bow truss
EX Shialleray 300
| 40 | Deep 300
Eil
| 42 | Simple-span wood joists
|43 | Shiallersy 16
| 44 | Deep 16
a5 |
| 46 | Simple-span Glulam wood beams
47 | Shialloray 50
| 44 | Deep al
Sl
| 50 | Overall Rise of the Frame The Depth of the Cantilever Maximum
|51 | Azzume length of cantilever is half of overall span Span
| 52 | Span Rise Length  Depth Depth Commonly
| 53 | Divider  Multiplier | of frame | of frame of at haze of | &t hase of Uzed
| 54 | for for L R Divider Multiplier Cartilever cartilever | cartilever ft)
| 55 | frame frame ft) [ft) far far Le d d Get from
| 56 | Rigid frame made from plates cantilever cantilever (ft) [ft) [in) Tahles
57 | Shialleray 120

58 Deep 120

Excel Tutorial 1
Page 9



